The payment function issue has been resolved. If you are still experiencing any issues, please open a new support ticket.
Posted Mar 25, 2025 - 07:46 CDT
Investigating
We are currently experiencing two issues affecting The Academy platform:
* Missing Log Out Button – The log out button is currently unavailable. To start a new session with a different user, please clear your browser cache or open a new browser type (e.g., switch from Chrome to Edge). * Payment Function Unavailable – Payments are not processing at this time. If you are trying to register for Regional Meetings, please contact your FBC with your headcount. They will ensure you receive a personal update once the system is operational.
Our team is actively working on resolving these issues. We appreciate your patience and will provide updates as soon as they become available.
Posted Mar 12, 2025 - 12:26 CDT
This incident affected: Studio Operations (Absorb The Academy).