Power BI KPI Reporting

Incident Report for The Bar Method

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 08:51 CDT

Identified

Data not updating since 3/7. We are currently experiencing data refresh issues in the KPI reporting. We will provide updates as they become available.
Posted Mar 10, 2025 - 16:03 CDT
This incident affected: Studio Operations (PowerBI).