CloudBeats access issue

Incident Report for The Bar Method

Update

We are continuing to investigate this issue.
Posted Nov 14, 2025 - 15:24 CST

Investigating

We know the ability to access studio music quickly and reliably is essential to your daily operations. Over the past week, some studios experienced issues in CloudBeats that affected both login and visibility of folders. We have identified a solution and workarounds should any studios notice this over the weekend. Please see the Resource Center for details: 📣Important Update: CloudBeats Music Access Fix and Weekend Workarounds - The Bar Method

Link: https://resourcecenter.sebrands.com/tbm/blog/2025/11/important-update-cloudbeats-music-access-fix-and-weekend-workarounds
Posted Nov 14, 2025 - 15:15 CST
This incident affects: Studio Operations (CloudBeats).