Support.barmethod.com - Latency Issues

Incident Report for The Bar Method

Resolved

This issue has been resolved.
Posted Mar 16, 2026 - 19:43 CDT

Investigating

We are currently investigating reported issues where there is intermittent access or significant latency on the support.barmethod.com page.
Posted Mar 16, 2026 - 13:14 CDT
This incident affected: Studio Operations (Support Portal).