Microsoft Azure Service Degradation

Incident Report for The Bar Method

Resolved

Microsoft has resolved the degraded service issue that impacted embedded reporting in The Bar Method dashboards.

Data refreshes should now be available. KPI visuals should also be loading as expected.

If you continue to experience any lingering issues, please reach out through our standard support channels.
Posted Jun 02, 2026 - 14:49 CDT

Update

We are continuing to investigate this issue.
Posted May 29, 2026 - 09:12 CDT

Investigating

Microsoft is experiencing degraded service, which is impacting embedded reporting in The Bar Method dashboards.

Note: This issue is impacting our ability to refresh yesterday’s data. You may also experience issues with KPI visuals loading in the dashboard.

We will provide another update as more information becomes available.
Posted May 29, 2026 - 08:06 CDT
This incident affected: Studio Operations (Dashboard, PowerBI).