Scam Awareness
Incident Report for The Bar Method
Resolved
We are now closing this post by marking as resolved.
Posted Nov 13, 2024 - 09:07 CST
Monitoring
Please be aware of a recent scam targeting fitness clubs and studios. Read this Franchise Notice on the Dashboard to learn more, including how to report the scam if you are contacted: https://resourcecenter.sebrands.com/tbm/blog/2024/11/reminder-stay-vigilant-to-scammers
Posted Nov 08, 2024 - 09:05 CST
This incident affected: Studio Operations (Support Portal).