PowerBI - Data Refresh Delay

Incident Report for The Bar Method

Resolved

The issue impacting KPI reporting has been resolved, and KPI data has now refreshed.

Visuals are now rendering as expected within the dashboard.

If you continue to experience any lingering issues, please reach out through our standard support channels.
Posted Jun 08, 2026 - 13:26 CDT

Investigating

We are investigating a data refresh delay within the Dashboard, KPI reporting is currently reflecting data through 6/6/2026.

Users may also experience issues with visuals not rendering properly.

We will provide another update as more information becomes available.
Posted Jun 08, 2026 - 10:50 CDT
This incident affected: Studio Operations (Dashboard, PowerBI).